Bavarian-Board.co.uk - BMW Owners Discussion Forum Homepage
Forum Home Forum Home > Technical & Model Specific Forums > BMW 5 Series
  New Posts New Posts RSS Feed - E39 2002 Blower Motor
  FAQ FAQ  Forum Search   Register Register  Login Login

E39 2002 Blower Motor

 Post Reply Post Reply
Author
Message
bookerfatz View Drop Down
Groupie
Groupie


Joined: 19-June-2009
Location: France
Status: Offline
Points: 99
Post Options Post Options   Thanks (0) Thanks(0)   Quote bookerfatz Quote  Post ReplyReply Direct Link To This Post Topic: E39 2002 Blower Motor
    Posted: 18-July-2017 at 09:48
Exactly one year ago I had my main blower motor (under dashboard) replaced along with the FSU module. Now the same problemhas arisen. Basically it just stopped blowing. At no speed ever. The old blower looked all dirty and the fan itself only turned with difficulty. I just wrote it off to age. Not sure what or why this has happened again. I've checked the main box fuses and nothing seems wrong there. I couldn't get at the 2 fuses larger fuses behind glove compartment. I surely don't want to have to replace the fan again but I have no idea why this is happening. We can feel cold air moving throughout he system though so I know the A/C is functioning.

Anybody else have this happen? Or a clue why?

Thanks.

2002 E39 530D M57 Touring.
Booker

2002 E39 5 series Touring


Back to Top
Sponsored Links


Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.