Bavarian-Board.co.uk - BMW Owners Discussion Forum Homepage
Forum Home Forum Home > Technical & Model Specific Forums > 'How To Do'
  New Posts New Posts RSS Feed - ON BOARD COMPUTER E34
  FAQ FAQ  Forum Search   Register Register  Login Login

Forum LockedON BOARD COMPUTER E34

 Post Reply Post Reply
Author
Message
stheaney2007 View Drop Down
Groupie
Groupie
Avatar

Joined: 02-August-2007
Location: East London
Status: Offline
Points: 85
Direct Link To This Post Topic: ON BOARD COMPUTER E34
    Posted: 19-September-2007 at 15:16

hello

I have an F-REG (88-89) 525i SE and on the dash it has an analogue clock. I was told you can take this out and fit an OBC. I removed the computer from a 535i. So I tool out the analogue clock and put the computer in. the connection were the same. But the computer doesn't light up. Its not blown as it worked on the 535i. Does anyone know how to get this working on my 525i

Thanks

Back to Top
Sponsored Links


Back to Top
doogie View Drop Down
Groupie
Groupie


Joined: 02-May-2007
Location: Barrhead
Status: Offline
Points: 80
Direct Link To This Post Posted: 19-September-2007 at 21:13
Sound like it could be pin 17? Have a look here

16 Feet of pure pleasure

DB02157, 01/90 E32 730i Calypso Red, single-point StarGas LPG conversion, Mac Mini on board
Back to Top
PaulS View Drop Down
Really Senior Member II
Really Senior Member II
Avatar
East Anglia BMWCC Regional Chairman

Joined: 03-July-2004
Location: Aylsham, Norfolk
Status: Offline
Points: 2516
Direct Link To This Post Posted: 20-September-2007 at 09:22

You beat me to it Doogie! I had the same problem - the only one left now is to find the plug to attach the outside temperature sensor! Mine still bongs and I haven't had the time to take the front bumper off to check whether its actually there!

Paul



95 E34 530i V8 Auto Maldives Blue
Back to Top
stheaney2007 View Drop Down
Groupie
Groupie
Avatar

Joined: 02-August-2007
Location: East London
Status: Offline
Points: 85
Direct Link To This Post Posted: 20-September-2007 at 10:01

Thanks for the help lads.

But will the computer go straight in. I mean once i take the clock out and that i just need to join the wire at pin 17 and thats it. i dont need anything else

 

thanks

Back to Top
PaulS View Drop Down
Really Senior Member II
Really Senior Member II
Avatar
East Anglia BMWCC Regional Chairman

Joined: 03-July-2004
Location: Aylsham, Norfolk
Status: Offline
Points: 2516
Direct Link To This Post Posted: 21-September-2007 at 09:18
Originally posted by stheaney2007 stheaney2007 wrote:

Thanks for the help lads.

But will the computer go straight in. I mean once i take the clock out and that i just need to join the wire at pin 17 and thats it. i dont need anything else

 

thanks

You will need to source another fascia panel as the obc is deeper than the clock, and the position of the plug is in the middle for the clock whereas the obc is at the top. They do come up on ebay, or ask the seller a question on any e34's being broken.

Paul



95 E34 530i V8 Auto Maldives Blue
Back to Top
stheaney2007 View Drop Down
Groupie
Groupie
Avatar

Joined: 02-August-2007
Location: East London
Status: Offline
Points: 85
Direct Link To This Post Posted: 22-September-2007 at 19:44

cheers for the reply guys,

i took the clock out, put the computer in. i had to saw the back of the holder so the computer would fit in. the bmwe34 website says join the red/grey/yellow to the red/yellow, i did that and it was very faint. so i joined it instes to the green/red, much better. when i tuned the ignition the computer said PPPP on the screen. my dash was dead as well. there was a slot for a fuse, i put that in, and everything is fine now. the computer is reading well.

The only thing is i dont know whether the computer still thinks its in the 535i that a got it from or is it reading my cars computer.

Does anyone know, it also doesn't keep the right time.

Back to Top
PaulS View Drop Down
Really Senior Member II
Really Senior Member II
Avatar
East Anglia BMWCC Regional Chairman

Joined: 03-July-2004
Location: Aylsham, Norfolk
Status: Offline
Points: 2516
Direct Link To This Post Posted: 22-September-2007 at 19:50

The obc is technically dead as PPPP comes up (means that it isn't fitted with a chip inside confirming cars details). Mine is the same, but does work fine. Have you changed the time on the obc?

Paul



95 E34 530i V8 Auto Maldives Blue
Back to Top
stheaney2007 View Drop Down
Groupie
Groupie
Avatar

Joined: 02-August-2007
Location: East London
Status: Offline
Points: 85
Direct Link To This Post Posted: 22-September-2007 at 19:55

I didnt fit the chip as the bmwe34.net website says. After i put a fuse in the obc is working perfect now. i took it for a test drive and pressed RANGE on the computer it said 42 miles left. as i drove around the range went down to 35 miles left. so it seems to be working. If yours is still saying PPPP then pop the bonnet there is a spare slot for a fuse. put one in, i did then it all worked.

When i set the time, it works. when i turn the car off and go back to it and start it up the time is the same as when i set it earlier. its not keeping the time

 

cheers

 

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.